Tea9源码网 - 免费分享精品源码、教程、软件|全网干货资源收集,免费下载。

黄金矿工脚本大全CPerformanceCounter类模块

发布:资源收集工2021-5-12 9:27分类: 易语言源码 标签: 易语言 黄金矿工 黄金矿工脚本 CPerformanceCounter类

源码说明

[e=0].版本 2

.子程序 GetCPUUsage, 双精度小数型, 公开, CPU占用率
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_Cpu ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_Cpu, #PDH_FMT_DOUBLE, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #双精度小数型, 5))
.如果真结束
返回 (0)

.子程序 GetRemainMemory, 整数型, 公开, 可用物理内存,MB
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_Memory ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_Memory, #PDH_FMT_LONG, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #整数型, 5))
.如果真结束
返回 (0)

.子程序 GetDiskReadSpeed, 双精度小数型, 公开, 磁盘读取速度,KB
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_DiskRead ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_DiskRead, #PDH_FMT_DOUBLE, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #双精度小数型, 5) ÷ 1024)
.如果真结束
返回 (0)

.子程序 GetDiskWriteSpeed, 双精度小数型, 公开, 磁盘写入速度,KB
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_DiskWrite ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_DiskWrite, #PDH_FMT_DOUBLE, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #双精度小数型, 5) ÷ 1024)
.如果真结束
返回 (0)

.子程序 GetNetDownloadSpeed, 双精度小数型, 公开, 网络下载速率
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_NetDownload ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_NetDownload, #PDH_FMT_DOUBLE, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #双精度小数型, 5) ÷ 1024)
.如果真结束
返回 (0)

.子程序 GetNetUploadSpeed, 双精度小数型, 公开, 网络上传速率
.局部变量 pdhValue, PDH_FMT_COUNTERVALUE

.如果真 (hCounter_NetUpload ≠ #NULL)
    .如果真 (Api_PdhGetFormattedCounterValue (hCounter_NetUpload, #PDH_FMT_DOUBLE, #NULL, pdhValue) ≠ #ERROR_SUCCESS)
        输出调试文本 (“Api_PdhGetFormattedCounterValue,性能计数器查询,数据请求失败。”)
        返回 (0)
    .如果真结束
    返回 (取字节集数据 (到字节集 (pdhValue.buffer), #双精度小数型, 5) ÷ 1024)
.如果真结束
返回 (0)
.子程序 GetMemoryLoad, 整数型, 公开, 内存占用比

返回 (MemInfo.dwMemoryLoad)

.子程序 GetTotalPhys, 长整数型, 公开, 总的物理内存大小

返回 (MemInfo.dwTotalPhys)

.子程序 GetAvailPhys, 长整数型, 公开, 可用的物理内存大小

返回 (MemInfo.dwAvailPhys)

.子程序 GetDrives, 整数型, 公开, 获取所有磁盘信息
.参数 drives_info, Drive, 参考 可空 数组
.局部变量 nBufferLength, 整数型
.局部变量 lpBuffer, 字节集
.局部变量 nSize, 整数型
.局部变量 nCount, 整数型
.局部变量 drives, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 drive, Drive
.局部变量 szName, 文本型
.局部变量 lpFreeBytesAvailableToCaller, 长整数型
.局部变量 lpTotalNumberOfBytes, 长整数型
.局部变量 lpTotalNumberOfFreeBytes, 长整数型

nBufferLength = 256
lpBuffer = 取空白字节集 (nBufferLength)
nSize = Api_GetLogicalDriveStrings (nBufferLength, lpBuffer)
lpBuffer = 取字节集左边 (lpBuffer, nSize)
drives = 分割字节集 (lpBuffer, { 0 }, )
nCount = 取数组成员数 (drives)
.计次循环首 (nCount, i)
    szName = 到文本 (drives )
    drive.Name = szName
    drive.Type = Api_GetDriveType (szName)
    Api_GetDiskFreeSpaceEx (szName, lpFreeBytesAvailableToCaller, lpTotalNumberOfBytes, lpTotalNumberOfFreeBytes)
    drive.TotalOfBytes = lpTotalNumberOfBytes ÷ 1024
    drive.TotalOfFreeBytes = lpTotalNumberOfFreeBytes ÷ 1024
    加入成员 (drives_info, drive)
.计次循环尾 ()
返回 (nCount)

相关截图

20210512092730.jpg
下载地址 
蓝奏网盘 百度网盘(提取码:tea9) 
温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 52 人阅读